Help Center

My JibJab Account →

What phone version do I need to run the JibJab app?

The JibJab mobile app requires that your phone run: 

iOS 10 or greater  

Android 6 or greater